mail1.hosted.site )No Cpanel Access
Incident Report for Domains.co.za
Resolved
This incident has been resolved.
Posted Nov 17, 2021 - 16:08 SAST
Monitoring
Found the issue and resolved it.
The mail server is up and running again.
Busy monitoring mail1.hosted.site connections and performance.
Posted Nov 17, 2021 - 13:50 SAST
Investigating
We are currently investigating the issue on mail1.hosted.site regarding Cpanel access and intermittent mail connection drops.
A further update will be provided shortly.

Apologies for the inconvenience caused.
Posted Nov 17, 2021 - 12:44 SAST
This incident affected: Email Only Hosting.