cp58.domains.co.za Down

Incident Report for Domains.co.za

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 00:12 SAST

Investigating

We are currently investigating an outage affecting the shared hosting server cp58.domains.co.za.

Our technicians are on-site and actively working to resolve the issue as quickly as possible. We appreciate your patience and will provide updates as more information becomes available.
Posted Sep 10, 2026 - 23:20 SAST
This incident affected: Web Hosting.