wp27.domains.co.za technical issues

Incident Report for Domains.co.za

Resolved

All Website and mail services have been restored. We sincerely apologize for the inconvenience this may have caused.
Posted Jul 16, 2026 - 19:11 SAST

Identified

We have identified an issue on the server wp27.domains.co.za, caused by an update process from the upstream provider.

We are actively working to resolve the issue and will post an update as soon as possible.

This is currently affecting all website and mail services.

We apologize for the inconvenience.
Posted Jul 16, 2026 - 18:41 SAST
This incident affected: Web Hosting.