The DDoS attack has subsided and all services have returned to normal operation. However, attacks of this nature can resume without warning. Our infrastructure team is actively monitoring the network and remains on standby to mitigate any further activity.
We will provide further updates should the situation change. Thank you for your patience.
Posted May 17, 2026 - 09:21 SAST
Identified
We are currently experiencing an Extremely Massive DDoS attack (over 100Gbps) which is impacting all services on our platforms. Our technicians are actively working on measures to try and mitigate the massive DDoS attack.
We will provide updates as soon as possible. We appreciate your patience with this matter.
Posted May 15, 2026 - 20:56 SAST
This incident affected: Network Infrastructure, Web Hosting, WordPress Hosting, Email Only Hosting, Email Filtering Services, Site Builder Services, Cloud Infrastructure, VPS Hosting, Reseller Hosting, and Domains API & Reseller Panel.