Ticket submission issue
Incident Report for Domains.co.za
Resolved
The issue regarding the ticket system has been resolved and ticket queries can be logged again.

We are working to clear the backlog of existing tickets.

Once again, apologies for any inconvenience that this has caused.
Posted Jun 04, 2021 - 21:33 SAST
Investigating
We are currently experiencing an issue with our ticket system regarding the logging of new tickets. We are investigating the issue and will provide an update shortly.

Tickets responses from our support, accounts and other departments will be delayed.

We apologize for the inconvenience.
Posted Jun 04, 2021 - 16:32 SAST
This incident affected: Domains Website (Website).