Mail filtering service down
Incident Report for Domains.co.za
Resolved
This incident has been resolved.
Posted May 19, 2021 - 14:00 SAST
Update
There was a complication during the Spam Experts audit on our mail filters which caused mail flow to stop.

Mail flow has been restored. However, there may be delays in mail flow due to a backlog of queued mails. This delay should be cleared up within 1 to 2 hours.

Once again, we apologize for any inconvenience that this may have caused.
Posted May 19, 2021 - 12:28 SAST
Identified
We are currently experiencing mail filtering issues on our Spam Experts servers. This is affecting incoming and outgoing mails.

Our upstream provider (Spam Experts) is currently investigating the issue.

We apologize for the inconvenience caused.

Updates to the issue will be provided shortly.
Posted May 19, 2021 - 12:05 SAST
This incident affected: Email Filtering Services.