wp25.domains.co.za down

Incident Report for Domains.co.za

Resolved

The faulty hardware has been identified and replaced.

All services have been restored.

Once again, thank you for your patience and understanding.
Posted Dec 04, 2025 - 18:57 SAST

Investigating

Currently the hosting server wp25.domains is down.

We suspect this may be due to a hardware failure.

Our technicians are on site and investigating the issue.

We will post updates as soon as possible.

Thank you for your patience and understanding.
Posted Dec 04, 2025 - 17:44 SAST
This incident affected: WordPress Hosting.