DDoS directed to Domains.co.za website
Incident Report for Domains.co.za
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 18:08 SAST
Identified
We are currently experiencing a DDoS attack against our website which may cause slow loading times.

Mitigation is currently ongoing.

We apologize for any inconvenience that this may cause.
Posted Jan 08, 2021 - 17:12 SAST
This incident affected: Domains Website (Website).