Payfast
Incident Report for Domains.co.za
Resolved
This incident has been resolved.
Posted Apr 30, 2023 - 12:32 SAST
Identified
Attention Capitec Customers
Please be advised that instant EFT is temporarily unavailable as a payment method. Kindly opt to pay using your credit or debit card instead.

Attention Standard Bank Customers
An issue with Standard Bank payments has been escalated. We will post updates when available.
Posted Apr 05, 2023 - 09:15 SAST
This incident affected: Domains Website (Payment Gateways).