Critical Vulnerability with cPanel & WHM Login Authentication

Incident Report for Domains.co.za

Monitoring

cPanel has released a patch for the recently identified authentication vulnerability, and we have applied it to all shared hosting servers and managed VPS environments. WHM, cPanel, and Webmail ports are now fully accessible on these systems.

Please note that these ports remain temporarily restricted on unmanaged Linux VPS servers. If your VPS is affected, a manual update may be required. You can follow the official cPanel guide here:

https://support.cpanel.net/hc/en-us/articles/40073787579671-Critical-Vulnerability-with-cPanel-WHM-Login-Authentication

We apologize for any inconvenience caused and thank you for your patience.
Posted Apr 29, 2026 - 00:34 SAST

Update

We are continuing to work on a fix for this issue.
Posted Apr 28, 2026 - 22:24 SAST

Update

We are continuing to work on a fix for this issue.
Posted Apr 28, 2026 - 22:07 SAST

Update

We are continuing to work on a fix for this issue.
Posted Apr 28, 2026 - 21:20 SAST

Identified

We are aware of a critical security vulnerability affecting cPanel/WHM login authentication method, as outlined in the official cPanel link below:

https://support.cpanel.net/hc/en-us/articles/40073787579671-Critical-Vulnerability-with-cPanel-WHM-Login-Authentication

Direct access to cPanel (port 2083), WHM (port 2087) and webmail (port 2096) will be unavailable from public networks until the exploit has been patched.

Services and websites remain fully operational.

We will continue to monitor the situation closely and will provide updates as necessary.

We apologize for any inconvenience caused and thank you for your patience and understanding.
Posted Apr 28, 2026 - 21:15 SAST
This incident affects: Web Hosting, WordPress Hosting, VPS Hosting, and Reseller Hosting.