Spam Filter Performance
Incident Report for Domains.co.za
Resolved
The incident has been resolved.
Posted Nov 21, 2023 - 08:02 SAST
Monitoring
Our upstream provider has implemented the fix, and this issue should be resolved. We are currently monitoring the situation.

Mails are already going out on time and the backlog is being processed as well.
Posted Nov 20, 2023 - 14:28 SAST
Identified
The root cause of the issue has been identified and our upstream provider is working on a fix
Posted Nov 20, 2023 - 13:30 SAST
Investigating
We are currently experiencing a decrease in the performance of our spam filter, and our upstream provider is in the process of investigating the issue.

This issue may cause a delay in the delivery of both incoming and outgoing emails. However, the mail server will periodically attempt to resend them from its queue.

We apologize for any inconvenience this may cause.
Posted Nov 20, 2023 - 12:32 SAST
This incident affected: Email Filtering Services.